Jump to content
The Klipsch Audio Community
Sign in to follow this  
Ciphoto

Freeze after Firmware Update Failure

Recommended Posts

I was going to update the firmware on my RSB 14 which I've only had a few months. So I downloaded the zip file, expanded it and put the two files on an empty 8GB flash drive from my mac.

I followed the instructions of unplugging the unit, inserting the flash drive and holding the volume up button while plugging the power cord back in. But Dolby light never came on. I waited several minutes. So i released the volume up button and unplugged the unit, removed the flash drive.

I confirmed i had the files on the drive, and I tried again. Still not dolby light. So i figured i would do it later after checking the forums and looking up some trouble shooting stuff. 

But now the unit will not work at all. I hook the power up the blue tooth and digital indicator light come on and stay on, but it is not giving any sound from my Apple TV, which i have hooked up via optical, i can not pair with my phone via blue tooth and it will not respond to it;s remote or the Universal remote i had programmed and had been using with it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...