Jump to content
The Klipsch Audio Community
Sign in to follow this  
fairenoughsirs

I bought 2.1 Promedia speakers and have no idea how to power it on

Recommended Posts

Hey. I bought some second hand 2.1 promedia speakers (without subwoofer) and I have no idea how to power them on. I will attach pictures to help explain. Essentially it comes with a control pod which has a green headphone cable, and another unknown cable that kind of looks like an s link. There were then two sets of monster cables that each plug into the back of a satellite speaker respectively. I have no idea how to a) attach the two speakers together and b) turn them on. Please help. Is the subwoofer necessary to turn on the satellites?

 

Pics: 

https://imgur.com/a/mSHOuRH

 

Share this post


Link to post
Share on other sites

Yes, the subwoofer is required to power the system. The subwoofer has the amplifier built in and you would plug your speakers in to the subwoofer, along with that "s link" cable. The 3.5mm jack would be plugged in to whatever source you desired. Unfortunately, the speakers and pod by themselves are of no use without the subwoofer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...