Jump to content


Photo
- - - - -

KMC1 WON'T CHARGE!

KMC1 CHARGE

  • Please log in to reply
2 replies to this topic

#1 spaceviren

spaceviren

    Newbie

  • Members
  • Pip
  • 1 posts
  • Offline

Posted 04 February 2014 - 09:44 PM

hello I'm from France and I received my new product KMC1 today, it works great but it won't charge! there is probably something wrong with it..

How can I resolve this problem please?



#2 Andy W

Andy W

    Forum Veteran

  • Klipsch Employees
  • PipPipPipPip
  • 1,043 posts
  • LocationIndiana
  • Offline

Posted 05 February 2014 - 11:45 AM

Will it play with the AC power adapter plugged in?

With the unit off and the AC power adapter plugged in, the volume indicator LEDs should show the level of battery charge.



#3 Turbox

Turbox

    Forum Veteran

  • Members
  • PipPipPipPip
  • 776 posts
  • LocationToronto
  • Offline

Posted 09 December 2014 - 07:17 AM

This same thing happened to me, klipsch sent me a procedure to remove the battery and reinstall it. that worked. it seemed to reset the charging controller inside the unit.


Big screen Big Sound.

 

2012 Cherry Jubilee's left and right, 3 Way with K402, K510
Centre channel 1984 La Scala bass bin with KPT335 MF/HF sections(K510/K69A & K703/K70G)
2011 KPT684 Centre Channel Subwoofer Powered by a Crown XTI1000.
2013 KPT435N - Left and right rears 3 way KPT904LF/K510/K703 with crossover from KPT4350-MS
2014 Cherry KPT-1802-HLS Subwoofer Powered by a Crown XTI1000.
Spare 1984 La Scala
Spare 2*KPT335 MF/HF sections(K510/K69A & K703/K70G)
Spares 1998 Heresy II's
Quintet 3.1 - Office
Quintet 3.1 - Bedroom