Jump to content
The Klipsch Audio Community
sharp3d

RSB-6 Sound Bar not powering on

Recommended Posts

I recently got an RSB-6 sound bar for use in my bedroom. When I first connected it to my TCL 55" Roku TV it worked great and had good sound.

 

I connected it via HDMI CEC using the ARC input on my TV. In order to get sound, the soundbar was set to it's HDMI input, this made sense. Once I was done setting it up, I powered the TV off which also powered the soundbar down. I powered the TV back on and the soundbar came on, then I turned the TV off again and the sound bar went off again. So far so good. 

 

The next time I turned the TV on was maybe 7-8 hours later. I powered my TV on, just as before my TV shut it's speakers off because it detected it was connected to the soundbar, however the sound bar didn't power on. When I tried to turn the sound bar on using the Klipsch remote, it still would not power on. I had to unplug the power adapter from the sound bar and plug it back in to get it to turn on. It seemed to work fine again after that. I could turn the sound bar on/off when I powered the TV on/off. However, if the soundbar sat in it's off state for too long, the only way to get it to power on again was to unplug it's power chord and plug it back in.

 

I checked for a firmware update and found one. I updated the sound bar to the latest version. After doing so, I no longer got sound. This was puzzling until I switch the sound bars input to "TV" then I was able to get sound. So before the firmware update the sound bar had to be set to HDMI input and after the update it had to be set to TV input. Weird but whatever. So I did the same thing, waited many hours to see if it would power on after being off. It seemed to work fine for about 2 days, but now it's doing the same thing. Won't power on via the TV being powered on or the Klipsch remote. Power cycle only.

 

Is there anything else I can do? Your help/advice is appreciated.  

Edited by sharp3d

Share this post


Link to post
Share on other sites

Hey Man, I have got the same issue with my new RSB-6.

My supplier said, it was because RSB-6 does support 4K  but my TV doesn't,  which was totally make no sense to me.

I have bought new HDMI cable and try but still doesn't work.

Right now, I am using the digital mode instead, it works fine, but I still need the HDMI to work, because the remote is very low quality and not going to last long.

Share this post


Link to post
Share on other sites

I have the same issue. I thought it was because my tv was old so I bought a new 55 inch LG 4K tv and the only way I can get it to work is via the fiber cable thru my Xbox. Otherwise I have unplug, reset, etc to get it to come on... 

Share this post


Link to post
Share on other sites

I had same problem with an RSB-6 sound bar,some times no sound, other times sound bar didn't turn on. I solve my problems by switching to an optical cable.

Share this post


Link to post
Share on other sites

I am using the optical cable and have this issue. Its inconsistent; sometimes it will power on, sometimes it won't. 

Share this post


Link to post
Share on other sites

Same problem with me / called klipsch they tell me they have never heard of this Problem.. 

Share this post


Link to post
Share on other sites

Same problem.  The remote won't turn the sound bar on.  I have to unplug the power from the back and then plug it back in after 10 seconds, it then turns on from the remote.

 

Anybody have any idea as to why this would happen after 2.5 years of good service?  (Despite a terrible remote, I hate this thing).

 

THanks - Tyler - 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...