Jump to content
The Klipsch Audio Community
Sign in to follow this  
Kawa

RP 600M Twitter issue

Recommended Posts

Hello Klipsch community,

 

So here's the issue, I am the lucky owner of a pair of RP 600M coupled to an Atoll IN50 but I am randomly losing the high range on one of the 2 speakers...

It happens every day to every few days and it comes back when I turn volume up (for example i'm in the middle of a movie when suddenly sound stop coming from one speaker's twitter, then if I turn volume quite up sound will come back, then I can put volume to a normal level and it will be OK for some time).

After some troubleshooting I excluded the source, the amp and the cables and can now say it is an issue with one of the 2 speakers.

I also noticed that sending high frequency (~15kHz) at high volume makes a crackling noise on the faulty speaker and it doesn't on the good speaker.

 

So here are my questions :

- Is it a know issue with a DIY fix ?

- If not, how do I get them fixed (I am in France and bought them from LDLC less than a year ago) and how long does it usually takes ?

 

Thanks a lot for the help.

Share this post


Link to post
Share on other sites

First thing to do is remove both the bi-wire jumpers for that speaker and reinstall it making sure it has a tight connection. 

Share this post


Link to post
Share on other sites

Hello, I have replaced the original jumpers by small cables.

Also during troubleshooting I have replaced those small cables with fresh ones and added banana plugs.

image.thumb.png.bb930657ce3049d709d771f936e67397.png

Share this post


Link to post
Share on other sites

Well, if they were purchased from an authorized retailed they are still under warranty so I'd contact that dealer if they are one.

  • Like 1

Share this post


Link to post
Share on other sites

Ok thank you, I hope I will not be without speakers many months.... Don't know if it has to be shipped back to US.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...