Jump to content

Need Help: Denon POA 1500 meter bulbs


HarryO
 Share

Recommended Posts

I just picked up a Denon POA 1500 amp and the lamps have been removed from the meter boards. "Snipped" off
IF anyone has specs on the bulbs and type of bulb I could sure use the help. I don't have a manual so after an hour of searching the web I figured I'll have to ask.
I know it's a long shot but "PICS and Specs/values" of bulbs would be great.
I HATE dark spots on the face of my gear.
Thanks so much,
Harry

post-24628-1381958387262_thumb.jpg

Link to comment
Share on other sites

I have a denon POA-1500 in black and had the bulbs replaced about eight months ago. They have already burned out. I will try to find the LED replacemant bulbs.

Here is part of a thread from Audiokarma.org:

#6
Old 08-04-2008, 12:35 PM
Banned
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 825
Quote:
Originally Posted by dr*audio View Post
The POA1500 uses a weird voltage lamp, as I recall. I can check the service manual when I get home, but I think it may have been a 24V lamp.
Its been a while since I serviced one but IIRC they were 28V/40mA.
Bill
Link to comment
Share on other sites

Thank You Bill for the info.

After I read the thread I did some local searches for the lamps but came up empty. Saturday later than most of my suppliers stay open. It looks like a monday morning project.

I love Meters!

Harry

Link to comment
Share on other sites

  • 5 months later...

Still looking for bulb specs? I just replaced mine last week. The amp had a known factory/design defect. They released a warranty kit consisting of a complete set of bulbs, two transistors and two resistors plus installation instructions. Unless you install the changed components, the bulbs will continue to burn out. I purchased the unit new in 87. Ordered the kit in 92' and my system sat in conditioned storage since. Work took me overseas on and off for several years. Finally found someone to install the kit last week. So don't waste your time with the bulbs unless you fix the defect. I have the instructions and parts list if you want it. Let me know. Unit and the preamp (POA-1000) were cleaned and work like new now. Excellent amp. Clean and quiet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...