Sign in to follow this  
Followers 0
rrommel

KMC-1 - suddenly dead?

5 posts in this topic

Hi,

Bought this one 1 month ago. Works perfect ... until yesterday. Wanted to use it in te morning, does not switch-on anymore.
No issues the day before. Was on the same place.

Charging: no lights/indicators. Touching or pressing or holding the soft-on on the top: nothing.

The charger itself works, it delivers 12 Volts as expected. Is there a fuse somewhere?

Anyone?

Share this post


Link to post
Share on other sites

Welcome to the Klipsch community. I am going out on a limb and think the KMC does not have a fuse. It may be a bad board in the unit.

Share this post


Link to post
Share on other sites

I would get in touch with klipsch support, after only a month, you should be able to get a new one.

Share this post


Link to post
Share on other sites

All,

Thanks. I indeed went back to my 'supplier'; they first said 'we take it, repair it, it will take around 3 weeks'.
He keyed in the infomration ... but the computer-system 'said': 'refund it, or give a new one'.

I looked for a new one in the store but apparently KMC-1 is not sold anymore, worse: no other Klipsch-systems I could choose from.

So ...I got my money back. That was a short membership @Klipsch ;-)

1 person likes this

Share this post


Link to post
Share on other sites

I'm not sure who your supplier is, but the KMC-1 is still for sale all over the place online. $299 at Best Buy, Walmart, Crutchfield, and B&H. Even a little bit less on Amazon. I would try another store in your area, if you need to get yours from a store.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0