Bcovish

Regulars
  • Content count

    29
  • Joined

  • Last visited

Community Reputation

4 Neutral

About Bcovish

  • Rank
    Member
  1. Yes. I did set them to small. Thanks. I did notice I have a through setting on my peq settings page which should bypass all the eq curves. And it looks like my sub is still playing. I guess I'm still learning all this new tech. My last avr I had for 10 years. A lot has changed for sure. Just need more time playing around with it. Thanks for the quick replies
  2. Ok guys need little help. I have a the klipsch RP series 5.1 HT set up being ran with a Yamaha rxa 1050. I did a ypao calibration and my HT sounds great but when I switch to music it doesn't sound great. I know it could be the awkward room and etc but help me at lest to get the avr set up right. If I use the pure mode it cancels out my sub. If I use straight will this bypass the Ypao calibration for the peq curves?? What settings or modes do y'all use for music. fwiw I checked the eq curves after the calibration and since I have an awkward shaped room my front left and right are totally opposite as far as the eq settings. One is 6db at 80 and the other is -6db at 80. Same goes for the midrange and highs. I know the room is everything but those seem to be extreme eq curves.
  3. Welcome to the dark side. I sometimes wish my room was a little smaller. I think you will enjoy Sent from my SAMSUNG-SM-N910A using Tapatalk
  4. Sheet rock anchor(50lb) with screw. Sent from my SAMSUNG-SM-N910A using Tapatalk
  5. I have the same size room. The 260 is more than enough with a sub. Sent from my SAMSUNG-SM-N910A using Tapatalk
  6. Love my yammy 1050. Never owned anything other than yamaha for about 35 years. Never had a single issue Sent from my SAMSUNG-SM-N910A using Tapatalk
  7. It's easy when we get new toys to hit a couple of buttons and all of a sudden things sound off. I agree above. No room eq for music. Let them puppies play. You might wat to do a reset on your reciever and start fresh making little adjustments at a time. If you find what you like write it down if you continue to experiment. When you can afford one pick up a klipsch sub so you can XO your towers. Part of this hobby is all about the experience and finding that sweet spot for your ears. Enjoy Sent from my SAMSUNG-SM-N910A using Tapatalk
  8. Hey op. I almost have the same set up. Rp260f Rp250cRp240sI have not been disappointed. In fact I have been very impressed. These are my first klipsch and coming from paradigm. They are very detailed and clear. Bought mine for HT and they excelled past my expectations. Some pink floyd on the rp260f rock. I honestly think unless klipsch drasticly changes anything I'll probably never change brands. I didn't mention the low end because we all know what klipsch can do. Just curious what avr your using? Sent from my SAMSUNG-SM-N910A using Tapatalk
  9. I almost pulled the trigger on cambridge couole of times. Let us know what you think. Sent from my SAMSUNG-SM-N910A using Tapatalk
  10. Lol. You are a better man than me. I would have ripped them out already. It would kill me. Sent from my SAMSUNG-SM-N910A using Tapatalk
  11. Derrick,, when you say more midrange is this at a loud volume otr upper level? Reason why I ask ..I knew a higher xo point helped with what you describe but do you think it matters when some one like myself listens at low to moderate levels. In terms of volume I rarely go past the half way mark if you will on the volume indicator. I'm seeking your knowledge not calling anybody out. Thanks Hey op not trying to high jack your thread just gaining some knowledge we both can use. Hope your enjoying your klipsch. By the way. What did you end up for you XO setting Sent from my SAMSUNG-SM-N910A using Tapatalk
  12. My rp260f are set large. Let them rock. I do run a 12inch sub Sent from my SAMSUNG-SM-N910A using Tapatalk
  13. Either way think you'll be happy between the two Sent from my SAMSUNG-SM-N910A using Tapatalk
  14. Great,,didn't think with that set up you would have any issues. Love my klipsch Sent from my SAMSUNG-SM-N910A using Tapatalk
  15. Op did you ever figure out the problem. Sent from my SAMSUNG-SM-N910A using Tapatalk