Jump to content
The Klipsch Audio Community

Recommended Posts

Hello, I have seen quite a few people post this issue but have seen no one respond about the issue to get fixed 

I own the rsb-14 soundbar with sub. There is a constant static noise, hissing sound coming from the 2 outside speakers of the bar. I contacted the dealer and got a new replacement soundbar. Yet still the issue persists?? Any reasons as to why? 

It happens through the optical and the hdmi-arc input. And the power source in plugged into monster power, power source. 

Share this post


Link to post
Share on other sites
Posted (edited)

I have the same issue.

Returned the soundbar only to have the replacement do the same thing. Did you find a resolution? Can this be expected to be normal?

Edited by jonathankoles

Share this post


Link to post
Share on other sites

Hi,

I have the same problem with my rsb-14 .

The technical support said this hiss noise is fine and there is nothing they can do about it.

Any one have solution for this annoying problem ?

 

Thanks 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...