Jump to content
The Klipsch Audio Community
Sign in to follow this  
PWJOKS

HD Wireless - Loosing connection between speakers and HD Wireless Control Center

Recommended Posts

Hi,

 

I own a REFERENCE PREMIERE HD WIRELESS 7.2 SYSTEM.

Once in a while i loose connection between my HD Wireless Control Center and my speakers. 
The only think I can do is to scan for new speakers to solve the problem. 

 

This is really annoying. I have contacted the retailer. They say I must return the system to their repair shop.
But now I'm thinking is this a know issue and Is there a fix for this problem?

Can it be that my and my neibhours 5ghz wifi interfer with my system? If so. Can I do something about it? 
To disable 5ghz is NOT an option for me and anyway are my close neighbours using 5ghz wifi as well.

 

Regards
PWJOKS

Edited by PWJOKS

Share this post


Link to post
Share on other sites

Hi, 

 

So fortunately or unfortunately (mostly the latter) I have the same issue.

 

My left front speaker keeps loosing connection with the HD Control center. I just purchased the system last week, the latest firmware is loaded on the system at least from what I can tell. 

 

This issue occurs daily and each time I have to factory reset the entire system and start with the setup process all over again which take 15 mins so this is getting fairly annoying now. If I go to the speaker status page when the issue occures, it shows that the front left speaker's MCU firmware is 0.0.0 which seems to be issue.

 

The most peculiar thing is that the right front speaker which I assume is part of the same pair does not loose connection nor my sub. Anyway long story short the left speaker from the pair of bookshelf's keeps loosing it's connection and the family is getting fairly frustrated. Please provide a solution any help you can provide to resolve this issue would be much appreciated.

 

Thanks,

Jay

Edited by dr3ad

Share this post


Link to post
Share on other sites

Anyone have any updates on this stuff? Is there any word from Klipsch? I've had the system for a year and a half, and it's been NOTHING but a game of rebooting speakers/hub. Now, for no apparent reason, my front left channel won't play any audio. This time, though, it still shows as connected in the system, and can play the audible beep when identifying. But, while watching something like netflix, no sound comes out without unplugging the speaker. And then it's just another cross your fingers moment while it decides whether or not to give up again.

 

I'm beginning to think that Klipsch has abandoned the HD wireless system, and the fact that there have been no updates to firmware seem to confirm that. Every day, my mind is blown that a company as big as Klipsch can sell a product as expensive as this, and offer ZERO support (not just for fixes, but seriously, that horrendous, straight-out-of-the-eighties user interface screen that has its own set of glitches..... really???). What really boggles my mind is trying to imagine what the target demo must think. I mean, I'm extremely tech-savvy, so this kind of nonsense is nothing new, so I just kind of roll with it. What's the non-tech purchaser thinking when their $5k home theater works whenever it feels like it? I just don't get it.

 

Bottom line: I love Klipsch, and have a LOT of Klipsch gear, but I'm stunned. 

  • Like 1

Share this post


Link to post
Share on other sites
On 12/14/2017 at 7:39 AM, draven said:

Anyone have any updates on this stuff? Is there any word from Klipsch? I've had the system for a year and a half, and it's been NOTHING but a game of rebooting speakers/hub. Now, for no apparent reason, my front left channel won't play any audio. This time, though, it still shows as connected in the system, and can play the audible beep when identifying. But, while watching something like netflix, no sound comes out without unplugging the speaker. And then it's just another cross your fingers moment while it decides whether or not to give up again.

 

I'm beginning to think that Klipsch has abandoned the HD wireless system, and the fact that there have been no updates to firmware seem to confirm that. Every day, my mind is blown that a company as big as Klipsch can sell a product as expensive as this, and offer ZERO support (not just for fixes, but seriously, that horrendous, straight-out-of-the-eighties user interface screen that has its own set of glitches..... really???). What really boggles my mind is trying to imagine what the target demo must think. I mean, I'm extremely tech-savvy, so this kind of nonsense is nothing new, so I just kind of roll with it. What's the non-tech purchaser thinking when their $5k home theater works whenever it feels like it? I just don't get it.

 

Bottom line: I love Klipsch, and have a LOT of Klipsch gear, but I'm stunned. 

I agree Daven.  I think they have given up on HD Wireless.  Trying too get help or solve problems is just crickets.  I did fix my dropping issue by moving my control unit away from my router but having so many more issues with the control unit itself.  Love love love Klipsch and these sound awesome but it's to were you just can't turn on directv or a movie, bluetooth or whatever and enjoy.  When it does work it sound great.  I've had mine almost two years.  A few things I wish I had done different. A. Went wired Klipsch when I finally retired my Infinity Interludes.  I have a 7.2, 4K Denon receiver but thought hey, Klipsch sound and no big receiver, sounds great.  I guess expecting to get the same thing from a small control unit that you get from a high end receiver was unrealistic.  B.  I wish that I had went RSB 14 sound bar and paired it with 5 or 6 RW-1's or RW-3's around the house.  The HD Wireless is not a whole home system.  You can add up to 7 speakers but it doesn't go through wifi, it's a signal from the unit so putting speakers on the back deck, bathroom, kitchen, etc... won't work.  C. I wish there was a way to use the speakers with my Denon receiver and ditch the crappy control unit.

 

So.  Here we are.  I'd like to sell mine locally at a big loss $$ but whoever I sell to would no doubt be calling, "Hey man, this sounds great but it doesn't work half the time".  I guess I'll either go back to wired or go with the soundbar/wireless speakers around the house.  The problem there is you can put RW-1's behind you in your living room to go with the bar and sub and you will get sound behind you but it is not true surround sound.  It's stereo at best.  No Dolby, no DTS so I'm prob not going that way either.  It's back to wired and my Denon receiver.  I guess this $3-4K system will go to the garage for tunes out there.  Instead of a $100 bluetooth speaker in my garage I'll have $3k Klipsch system just to steam Pandora.  Nice!!  My fault for not waiting until I could make sure this was going to work but my thinking was it's Klipsch.  It's got to be awesome...  And then there was the promise of lifetime software and even hardware replacement if it was ever needed for updates.  That hasn't happened and at this point I'm with you.  It never will.

  • Like 1

Share this post


Link to post
Share on other sites

I want to start off by saying that I am a long time Klipsch user / customer (over 30 years)

I recently purchased the HD Wireless system for a new Theater / projector I setup. When it works right, I LOVE the sound!!! However, it is embarrassing 

when you have guests over...  

I have emailed Klipsch tech support, & have not even received a courtesy canned email response back; Just totally ignored me.

I really hope Klipsch has not abandoned this system! It really is good! I will be attending CES in Las Vegas in a few weeks & will be speaking to the Klipsch reps there to try to find out about the status of the HD Wireless System. I'll report back here what I find out.

This system is supposed to be "Future Proof" so if Klipsch does go with another wireless system, they better not forget about us!

  • Like 2

Share this post


Link to post
Share on other sites

Wow this is getting out of hand. I really feel for you guys. I’m having issues with a pair of RW 1’s. The play fi Klipsch app is worthless and it’s so frustrating. I cannot get them to play at all. I tried it earlier today after I re set it up. It played for half a song and it disconnected. That’s how it goes all the time. I thought I was the only one. So it seems nothing is being done. Im just going to return them. Only had them for a few days. One was suppose to be a Christmas present. The sound is pretty good but it doesn’t matter if the speaker won’t work. The worse part is that the only way you can use it, is through the piece of trash app. They really screwed up big time. No Bluetooth or anything. Just WiFi. I don’t know who Came up with these ideas but they need to get fired.


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

I've had my system for a couple of weeks and it seems to work quite good. The sound is amazing and only had a few issues with some very short transmit losses. Not a big problem as it has happened rarely. So far no problem which has me to reconnect speakers or restore to factory. I do see some users here complaining about poor support from Klipsch and the lack of steady firmware updates. I agree that this is not the way to go with their customers.. A simple blog post with status and what to expect would ease a lot of frustration. Will be interesting to see what @Hollywood7 report back after CES.

Share this post


Link to post
Share on other sites

I've had the hd wireless setup for about a year and a half now.  I had issues where speakers would not automatically connect up on boot for nearly the whole time I've had the system.  Maybe 6 months ago I disabled "auto power sync" on my LG television.  Now I leave the control center on all of the time and I haven't had any system issues beyond being unable to fully use the LG magic remote to operate the control center, though Klipsch had said that was an issue on LG's end.

Share this post


Link to post
Share on other sites

My latest issue with the HD Wireless system is when I set it to HDMI1 (Normal setting to watch TV via ATT UVERSE); My two rear surrounds default to Left Side & Right Side, instead of Left Rear & Right Rear.

While I don't think this changes the sound in a 5.1 system, I would still prefer it to be set to Left Rear & Right Rear.

I have reset the system back to default, tried removing the Left Side & Right Side & then re-adding back the Left Rear & Right rear but when I look at the back of the two surround speakers, the light on the back has reverted back to Left Side & Right Side.

Share this post


Link to post
Share on other sites
On 2.1.2018 at 8:45 PM, Hollywood7 said:

My latest issue with the HD Wireless system is when I set it to HDMI1 (Normal setting to watch TV via ATT UVERSE); My two rear surrounds default to Left Side & Right Side, instead of Left Rear & Right Rear.

While I don't think this changes the sound in a 5.1 system, I would still prefer it to be set to Left Rear & Right Rear.

I have reset the system back to default, tried removing the Left Side & Right Side & then re-adding back the Left Rear & Right rear but when I look at the back of the two surround speakers, the light on the back has reverted back to Left Side & Right Side.

 

This is apparently something with Dolby considering the rear channels as side channels and as I understand does not change the sound.

Share this post


Link to post
Share on other sites

Hi All,

I just returned from CES (Consumer Electronics Show) in Las Vegas, & I had a chance to speak with the Klipsch reps.

What my concern was if Klipsch was still supporting the HD Wireless speaker system. The reason for the concern is there has not been any updates since May 2016!

Like many of you on this forum, I have intermittent issues with 1 or more speakers dropping offline (LED flashes) where you have to re-run the setup to get it back. It’s a minor annoyance.

The Klipsch representatives assured me without a doubt, that they are still supporting the HD Wireless system, & that engineers are working on updates which should be coming out soon.

The HD Wireless speaker system is a great system, but it does have (small) issues that I hope are taken care of in future firmware updates.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/2/2018 at 1:45 PM, Hollywood7 said:

 My two rear surrounds default to Left Side & Right Side, instead of Left Rear & Right Rear.

While I don't think this changes the sound in a 5.1 system, I would still prefer it to be set to Left Rear & Right Rear.

Why?  In a 5.1 system you use side, not rear surrounds.  Plus what difference does it make what the device calls them?

Share this post


Link to post
Share on other sites
On 13.1.2018 at 6:59 PM, Hollywood7 said:

Hi All,

I just returned from CES (Consumer Electronics Show) in Las Vegas, & I had a chance to speak with the Klipsch reps.

What my concern was if Klipsch was still supporting the HD Wireless speaker system. The reason for the concern is there has not been any updates since May 2016!

Like many of you on this forum, I have intermittent issues with 1 or more speakers dropping offline (LED flashes) where you have to re-run the setup to get it back. It’s a minor annoyance.

The Klipsch representatives assured me without a doubt, that they are still supporting the HD Wireless system, & that engineers are working on updates which should be coming out soon.

The HD Wireless speaker system is a great system, but it does have (small) issues that I hope are taken care of in future firmware updates.

 

GREAT NEWS! thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...