Jump to content
The Klipsch Audio Community
gprime38

Promedia 2.1 speakers only work on one speaker until I turn the volume knob to max. Help?

Recommended Posts

The issue I'm having is that the speakers only play from one side until I turn the volume knob up, and then it comes out balanced. I could live with this issue but there's some other wonky stuff happening too. Sometimes, I'll turn the volume knob and then it will remain constant even if I turn the knob up and down. So, even with the knob turned all the way down, sound will still come out. I'm not very versed with this kind of stuff, but any idea what the issue is?

Share this post


Link to post
Share on other sites

Power supply or amp problem

Reverse the inputs to your Promedia amp and see if the problem moves to the other speaker

If the problem remains the same, the system needs to go to the shop, est $150 for any repairs

Currently 100 for a new system at Costco on sale now

Share this post


Link to post
Share on other sites

Klipsch sells a replacement volume pod, for a reasonable price. I’d almost bet that would solve your problem. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...