Jump to content
The Klipsch Audio Community
Sign in to follow this  
Drewski

Tower Speaker (RP-250F) Bass Response

Recommended Posts

My current configuration consists of a 5.1.2 setup. Kind of a newbie question but my front towers do not get much bass when listing to music or watching movies. Pretty much all bass goes to the LFE channel. However, I would like to disable the sub sometimes. Mostly for late night viewing. 

 

I tried setting my crossover to 50hz and 80hz. I also tried enabling double bass. It may be a content issue, if I try a "bass test" video on YouTube the towers have noticeable woofer movement and air pressure from the ports. If I am listing to music or a movie they do not produce much bass. 

 

Speakers

  • L/R - RP-250F
  • C - RP-250C
  • Surround - RP-150M
  • Height - RP-140SA
  • Sub - R-112SW

AVR

  • Pioneer Elite VSX-LX301

Inputs

  • Apple 4K TV
  • Oppo UDP-203

 

Share this post


Link to post
Share on other sites

For maximum bass you'll have to run them as Large.  Have you tried that yet?

 

Some receivers have a dynamic volume setting that helps for low volume listening.

  • Like 1

Share this post


Link to post
Share on other sites

 

2 minutes ago, wuzzzer said:

For maximum bass you'll have to run them as Large.  Have you tried that yet?

 

Some receivers have a dynamic volume setting that helps for low volume listening.

 

Yup, I tried running them both has Large and Small.

Share this post


Link to post
Share on other sites

Well, the smaller woofers in the 250s aren't going to produce nearly as much bass as your very capable subwoofer will.  Maybe just lower the sub's output level for night listening?  Or play with any tone or EQ controls available for the 250s?

Share this post


Link to post
Share on other sites
On 11/28/2018 at 9:45 AM, wuzzzer said:

Well, the smaller woofers in the 250s aren't going to produce nearly as much bass as your very capable subwoofer will.  Maybe just lower the sub's output level for night listening?  Or play with any tone or EQ controls available for the 250s?

 

So, I messed around with the EQ a bit. Looks like when I used the microphone to auto-configure the system with MCACC it removed all the bass response from the towers. I disabled it completely and it's a world of difference.  I'm going to a little more testing with setting the fronts back and forth from Small/Large, Crossovers between 50 and 80 and Double Bass. 

  • Like 1

Share this post


Link to post
Share on other sites

I would still recommend using a subwoofer with your system. I'm using a RP250 set up mainly for 5.1 music only. RP250F x 4 piano black and Rp250C PB. I am using with a 10 inch HSU subwoofer. I've tried it without a sub, while musically still very good, adding in the sub really opened things up in the soundstage and bass of course. I have all set to small with sub at 80HZ. 

For the size of the speakers its impressive. 

Share this post


Link to post
Share on other sites

I would not disable MCACC or set the speakers to large.  Did you jack-up the bass?  Are you in an apartment? You can always listen in the stereo mode late night.  Which Pioneer avr do you have?

Share this post


Link to post
Share on other sites

Based on your tests I think where you have them positioned in the room is causing problems.  Mcacc is only looking at the response and deciding what it can work with.

 

Move the fronts back towards the wall some or closer to corners it will bring them alive in the bass area.

 

I had the predecessor and it was good down to 30hz nicely.  Those have plenty of bass they are not positioned right is my best guess.

 

 

Share this post


Link to post
Share on other sites
On 12/6/2018 at 3:42 PM, Kman said:

I would still recommend using a subwoofer with your system. I'm using a RP250 set up mainly for 5.1 music only. RP250F x 4 piano black and Rp250C PB. I am using with a 10 inch HSU subwoofer. I've tried it without a sub, while musically still very good, adding in the sub really opened things up in the soundstage and bass of course. I have all set to small with sub at 80HZ. 

For the size of the speakers its impressive. 

 

Very much so, I love these speakers. I have not disabled the sub, just dialed the gain back a bit so it isn't so boomy at night. 

 

 

On 12/6/2018 at 4:23 PM, derrickdj1 said:

I would not disable MCACC or set the speakers to large.  Did you jack-up the bass?  Are you in an apartment? You can always listen in the stereo mode late night.  Which Pioneer avr do you have?

 

It is a shared family room 23'L x 11'W x 7'H where the main seating area is 8.5'L x 11'W  x 7'H. AVR is VSX-LX301

 

Untitled.png.c518ec005ae1ab8e86417c3d6e66c527.png

 

On 12/9/2018 at 10:50 AM, RoboKlipsch said:

Based on your tests I think where you have them positioned in the room is causing problems.  Mcacc is only looking at the response and deciding what it can work with.

 

Move the fronts back towards the wall some or closer to corners it will bring them alive in the bass area.

 

I had the predecessor and it was good down to 30hz nicely.  Those have plenty of bass they are not positioned right is my best guess.

 

 

 

The 250Fs are about a foot from the wall toed in a bit.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...