Jump to content
The Klipsch Audio Community
Sign in to follow this  
Lost240

Forte IIs in CT

Recommended Posts

Worth it would say. The labels look alright anyway...

  • Like 1

Share this post


Link to post
Share on other sites

I believe (but I might be wrong) these had been on Craigslist a couple of times within the last year or so (although it may not be the same seller). The guy I was texting back then  revealed that the woofers were not original (replacements of some sort - but "they fit and they work"). The cabinets and grilles were quite beat up. My friendly advice is be very suspect, although I can't be certain if these are the same cabinets or the same seller.

  • Like 2

Share this post


Link to post
Share on other sites

The woofers appear to be correct. The cabs are beat, dog piss grills missing badges. I would be able to fix these but not worth the effort for me for more than $200. Great project though.

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...