Jump to content
The Klipsch Audio Community
Sign in to follow this  
ezmoney68

old school intent with new set up

Recommended Posts

This forum provides a wealth of knowledge and I want to thank everyone for their input.  I apologize in advance for this lengthy story, but hopefully some of you can relate.

 

My first nice system in 1988 consisted of a pair of Quartet speakers and a NAD integrated amp with a NAD 6 disc cd changer.  I remember the day the salesman played those speakers and it felt like someone was standing there thumping my chest!  I was hooked.

Over the years, I added a Klipsch sub, center and surrounds for the home theater experience with my Pioneer Elite 65" TV and upgraded to a NAD T770 receiver.  I could blow the windows out of the house with that system.

After a divorce, a move into a different house and an upgrade on some technology, I find myself puzzled.

I purchased a new TV and blue ray player.  Of course my old components did not have HDMI imputs.  Normally, I do extensive research before purchasing anything, but a big orange "SPECIAL" sign led me to purchase a Sony ES 7.1 channel home theater receiver with more inputs/outputs than the space shuttle.  The ease of connection, reduction in wires, and advertised superiority of the HDMI was attractive to me. 

With the new house and extended hours at a new job, I rarely exploited the system.  While I was out of town, an unexplained incident with a house sitter or teenaged son seemed to blow all the woofers from my system.  Out of frustration, I let the system sit idle for quite some time.

After a windfall, I decided to treat myself to some new speakers.  The whole home theater set up has lost its appeal to me......and what I really enjoy is listening to my music.  With this being said, I moved the surround set up to the master bedroom with the intent of reconing the woofers eventually and ordered a pair of Cornwall IIIs for my TV/Listening room.

I was as excited as a little kid at Christmas as I slid those speakers out of the box.

(My wife was a little less excited when she saw the size of the Cornwall IIIs, but that is another story.)

Here is where I need the forum's help.  When I hooked up the speakers and played a few CDs, I was pretty underwhelmed.  I chose not to biamp the speakers initially because everything I read seemed to be split down the middle whether it was beneficial or not.

I was being cautious at first with the volume, especially after the blow out of the previous set up.  I carefully increased the volume and the sound was crisp, with no distortion or hiss, but the sound just seemed flat.

This receiver has the microphone that you position so that it takes measurements of the room etc and I went through all those steps.  I even went in to the digital equalizer and increased the bass levels, which helped round out the sound somewhat.  After these adjustments, I increased the volume, but nowhere near pissing off the neighbors levels and the left speaker started to pop.  I turned down the volume as quick as I could, but it had popped about three times.

Do you think the receiver has an issue from the previous incident?  Is it not good enough to drive this speakers?  My old NAD equipment had no issues driving my speakers and I had researched its quality.  Is a lack of power to the speakers causing the popping?  Is that popping referred to as clipping?  Since I do not care about the surround sound and am going to a 2 channel set up, would biamping give more power to the speakers and eliminate this issue?

Any advice is welcomed and I appreciate everything in advance. 

 

Share this post


Link to post
Share on other sites

Some members really don't care for the Sony receiver/Klipsch speaker combo.  Which model do you have?

Share this post


Link to post
Share on other sites

Popping noise sounds like and amp or speaker electrical issue not related to avr Brand.  My Sony avr never causes popping.  This ES series is high quality for Sony.  Switch the speakers around and see if the pop follows the speaker or stays on the left side.  How old is the avr?

Edited by derrickdj1

Share this post


Link to post
Share on other sites

Hook the NAD T770 up to the CIII's and see(hear) what you get.

 

My NAD T773 will make my Heresys rip.

 

Bill

  • Like 1

Share this post


Link to post
Share on other sites

I have never heard anybody say they were underwhelmed by CW 3's. 

 

By the sound of everything you said, whatever killed the woofers in those Quartet's probably caused some damage in the Sony's amp area. Who knows, lightning may have hit the thing. 

 

I don't think 3 pop's hurt anything. If they did, it would be the tweeter first.

Edited by mustang guy

Share this post


Link to post
Share on other sites

The pops are the woofer bottoming out against the back plate.  You must of had quite a bit of eq'd bass dialed in and running them at a pretty high level to cause the woofers to pop.  Won't hurt them just don't make it a habit.

  • Like 1

Share this post


Link to post
Share on other sites

There must have been a huge issue with the Sony amp.  I hooked up the old NAD and the speakers sounded perfect.  If it was an amp issue, the woofers may have not been blown on the original speakers after all.  Oh well, new setup and system for the bedroom now as well. 

Thanks for all of the help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...