Jump to content
The Klipsch Audio Community
Sign in to follow this  
neobundy

R-112SW Randomly Shuts Off

Recommended Posts

1 minute ago, wvu80 said:

 

You would not use the plate amp at all, don't even plug it in.

 

Open up the sub and unhook the connectors that attach to the sub driver's +/-.  An external amp (not AVR) such as an Inuke 3000 would then bypass the plate amp connecting directly to the sub drivers.

Got you, I Though it was just a connection in the back. Will do that if happens out off warranty. Thanks

Share this post


Link to post
Share on other sites
2 minutes ago, yolayoe said:

Got you, I Though it was just a connection in the back. Will do that if happens out off warranty. Thanks

 I hope Klipsch steps up to the plate (amp) and takes care of you.  Good luck.

Share this post


Link to post
Share on other sites
13 minutes ago, wvu80 said:

 I hope Klipsch steps up to the plate (amp) and takes care of you.  Good luck.

 

Isn't the sub amp warranty for two years? and the woofer for 5? They need to fix it or replace it. It is just 4 month old. Will let u know  Monday.

  • Like 1

Share this post


Link to post
Share on other sites

Yes.  if it's that new and you bought it from an authorized dealer then it should be fixed at no charge to you. 

  • Like 1

Share this post


Link to post
Share on other sites

Does anyone have the same issue with the 15" ones? I may consider to ask them to exchange it for the r-115sw and pay the difference.

Share this post


Link to post
Share on other sites

They are sending me a new amp plate and weird that they don't want back my old one. 

Share this post


Link to post
Share on other sites
2 hours ago, yolayoe said:

They are sending me a new amp plate and weird that they don't want back my old one. 

Shipping cost is my guess.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, derrickdj1 said:

Shipping cost is my guess.

Yea or they know its a POS.

Share this post


Link to post
Share on other sites

Have this exact same issue with a six month old R-112SW.   Klipsch is sending a replacement no questions asked so at least they're taking care of it.  I'm hoping if there were bad batches on the amp that if they're aware of it, the new one will be good to go so we'll see.

Edited by dancefreak

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...