Jump to content
The Klipsch Audio Community
Mr500cm

Wiring question

Recommended Posts

I'm new so please forgive my lack of knowlege here.....I have a set of Klipsch RP-160M speakers, a vintage Fisher reciever and a Sony HAP-S1 media player. The reciever sounds great with the speakers, using the radio, but when I'm playing the medai player through them I'm losing top end. Now when I use the media players built in amp with the RP-160's the sound is a lot better. Is it possible to wire the reciver and media player to the speakers (there are two inputs) but one use once source at a time either the reciver or media player. I'm pretty sure I can but I just want to check.

 

Thanks

 

Lance

Share this post


Link to post
Share on other sites

You could easily damage one or the other amps that way.  

 

You're not connecting the Sony to a phono input on your Fisher are you?  Have you tried different inputs on it?

Share this post


Link to post
Share on other sites

If you use something like a Niles spk-1 you will be able to do what you want and not damage anything. You can find them on eBay.

 

Share this post


Link to post
Share on other sites

You need a speaker selector switch box.  Lots out there.  Don't try to use something that drops the output of the media player's amplifier to run into the receiver.  I don't think that will help in your situation and likely would degrade the sound further.  Partsexpress has some reasonably priced ones along with monoprice.

Share this post


Link to post
Share on other sites

 One question. These are bi-wire speakers. How are you connecting them? 

 If the binding posts are strapped the set up  used is not critical. If not strapped together the two sets of  binding posts(inputs) need to be connected to your amp. 

  

Share this post


Link to post
Share on other sites
8 hours ago, Panelhead said:

 One question. These are bi-wire speakers. How are you connecting them? 

 If the binding posts are strapped the set up  used is not critical. If not strapped together the two sets of  binding posts(inputs) need to be connected to your amp. 

  

They are as they left the factory, strapped together.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...