Jump to content
Cody_Mack

The Three - Will Not Power On!

Recommended Posts

Finally getting around after back surgery and getting (Mother's Day gift) "The Three" up and running. Darn thing will not power on! At least I don't think it is. There are no LEDs lit up, nothing audible with my ear up to the unit while rotating input selector and volume, etc. Not visible as a Wi-Fi device from the App. I measured 120VAC at the end of the power cord. Anyone have a clue? I have already had one return on this order; they sent The One instead of The Three!

 

Rick

 

Share this post


Link to post
Share on other sites

Have you tried a factory reset? I think its page 19 of manual.

Share this post


Link to post
Share on other sites
18 hours ago, rockhound said:

Have you tried a factory reset? I think its page 19 of manual.

Yessir

Share this post


Link to post
Share on other sites

Man that sucks will be curious to hear your resolution as I have a Three also.

Share this post


Link to post
Share on other sites
On 6/4/2017 at 9:06 AM, Cody_Mack said:

... and getting (Mother's Day gift) "The Three" up and running. 

Rick

 

This could be the karma gods dishing it out for getting yourself a gift on mother's day:lol:

Share this post


Link to post
Share on other sites
On ‎6‎/‎5‎/‎2017 at 3:22 PM, haydukej said:

This could be the karma gods dishing it out for getting yourself a gift on mother's day:lol:

Ha! It is very suspect, isn't it? Honestly, it was for her; she has complained since the digital file age started, that she just don't know how to find/play music anymore. She is soooo not tech-savvy. I thought this unit would make it easier for her. But probably not, so I returned it!

 

On ‎6‎/‎5‎/‎2017 at 3:11 PM, rockhound said:

Man that sucks will be curious to hear your resolution as I have a Three also.

Returned it. I think karma is telling me I should have ordered from Corey!

Share this post


Link to post
Share on other sites
On ‎6‎/‎4‎/‎2017 at 9:10 AM, jimjimbo said:

Call Customer Service?

Yes, he was no help. It was surprisingly easy to get to talk to a human, however!

Share this post


Link to post
Share on other sites
4 minutes ago, Cody_Mack said:

Yes, he was no help. It was surprisingly easy to get to talk to a human, however!

If that's the case, you should return it.

Share this post


Link to post
Share on other sites
14 hours ago, jimjimbo said:

If that's the case, you should return it.

Skimming the threads again Jim?

Share this post


Link to post
Share on other sites

I obviously love Klipsch products but would never buy anything they make with an amp in it.  They just scare me.

  • Like 2

Share this post


Link to post
Share on other sites
On 6/8/2017 at 9:44 AM, CECAA850 said:

I obviously love Klipsch products but would never buy anything they make with an amp in it.  They just scare me.

They just can't seem to get it right.

 

Klipsch should stick with passive, that's what they do best.

 

Bill

  • Like 1

Share this post


Link to post
Share on other sites
On ‎6‎/‎15‎/‎2017 at 10:28 AM, rockhound said:

What did you end up doing?

I returned it. Probably would have been too complicated for her anyway. Maybe try again later on when Klipsch works out some of the bugs.

 

  • Like 1

Share this post


Link to post
Share on other sites
On ‎6‎/‎15‎/‎2017 at 10:28 AM, rockhound said:

What did you end up doing?

Another thread skimmer, LOL.

Share this post


Link to post
Share on other sites

Next time get the hand crank one or upgrade to the wind up one. Guaranteed not to break. Of course your arm might get tired... :D

I too was worried about the bugs on first gen stuff so I'll wait. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×