Jump to content
The Klipsch Audio Community
Sign in to follow this  
Amstaff

Another RSW 15 bites the dust

Recommended Posts

5 hours ago, babadono said:

Are you handy with that there voltmeter? I can send you a PDF of the service manual if you like. Drop me a PM if so.

I appreciate the offer - the parts are on their way to Edwards Electronics. 

 

I am considering a second sub - not sure what yet. I am intrigued by the DIY ones - Scrappydue's thread really peeked my interest.

 

 

Share this post


Link to post
Share on other sites

I will keep tabs on this. I may buy an RSW15 with blown amp as well... offered at $150 US near me.   I already have a 400Watt rms rack amp... so it may be an easy connect if I cannot fix the bash amp.  Will have a go at it.  

Share this post


Link to post
Share on other sites

Definitely get the amp repaired. The sub is worth pennies unless it is repaired and worth at least as much of the repair or more. 

 

Share this post


Link to post
Share on other sites

The parts arrived at Edwards Electronics this week Tuesday. I hope to have them back in a few weeks.

A question for y'all: I removed the speaker and the passive - Klipsch used a real thin sealing tape on them. It seems aftermarket tape is all like weatherstripping tape (thin'ish foam). I assume I will need to seal it went putting it all back together. Is the foam tape OK for that?

 

Thanks - will keep this thread posted on progress.

 

 

Share this post


Link to post
Share on other sites

HooHoo - my repaired stuff is on its way back from Edwards Electronics eta late next week (11/17).

I have ordered some gaskets:

http://www.simplyspeakers.com/speaker-gasket-replacement-repair-gas-15.html

and

http://www.parts-express.com/parts-express-speaker-gasketing-tape-1-8-x-3-8-x-50-ft-roll--260-540

the PE stuff both 3/8" and 1/2"

 

Anyone better than the other?

I am still itching to build a 18" box - we will see.

 

Share this post


Link to post
Share on other sites

 Homedepot has similar stuff and if it is the wrong size, it's and easy exchange.

Share this post


Link to post
Share on other sites

thanks derrick - I have some HD "window stuff" in my garage, old though. The PE  stuff,  if it's the same, is a premium price...all good if my sub is kicking *** in a week or two - happy, happy, joy, joy.

 

I have noticed since the RSW-15 has been out of order - the RS-7's put out some good bass too. Switched the Denon 4311Ci to large fronts....not too bad.

 

If the RSW-15 does not kick *** like it used to - out with the old :-)

 

Thanks for everyone's input!

Share this post


Link to post
Share on other sites

The RSW-15 is back in business. Parts arrived today Tuesday (NC) not bad for FedEx ground from AZ that shipped on Friday.

Just got the sub put back together - works like it used to. 

 

Kudos to Edwards Electronics, turn around time was in line with expectations  -around 3 weeks door to door. Could not tell what component was replaced - but it works great. If your sub goes bye-bye I would recommend checking them out.

 

 

  • Like 2

Share this post


Link to post
Share on other sites
On 11/15/2016 at 6:55 PM, jjptkd said:

Glad to hear it! There wasn't a repair slip with a parts list?

No, no repair list. The ad was "send us your stuff, pay us and it will work again" I did and it does.

 

Share this post


Link to post
Share on other sites

2 week update - 

 

I had forgotten how awesome this thing is - wife is playing some Rammstein as I type.

 

It is probably me - but it seems better than it ever was.

 

One happy camper here.

 

  • Like 3

Share this post


Link to post
Share on other sites
2 minutes ago, Amstaff said:

2 week update - 

 

I had forgotten how awesome this thing is - wife is playing some Rammstein as I type.

 

It is probably me - but it seems better than it ever was.

 

One happy camper here.

 

 

That is just awesome right there!!

Share this post


Link to post
Share on other sites
On 10/19/2016 at 4:51 PM, twk123 said:

deleted

Share this post


Link to post
Share on other sites
On 2016-10-28 at 2:59 PM, Amstaff said:

The parts arrived at Edwards Electronics this week Tuesday. I hope to have them back in a few weeks.

A question for y'all: I removed the speaker and the passive - Klipsch used a real thin sealing tape on them. It seems aftermarket tape is all like weatherstripping tape (thin'ish foam). I assume I will need to seal it went putting it all back together. Is the foam tape OK for that?

 

Thanks - will keep this thread posted on progress.

 

 

I'm thinking of contacting Edwards Electronics to fix my RSW-12.

 

i noticed you mentioned removing the speaker.  Will I have to do that or just remove the amp?

Share this post


Link to post
Share on other sites

I removed both - speaker and passive.

The amp is in the middle of the box, between the "speakers" - at least it was on the RSW-15. Maybe you could get way with only removing one or the other- i dont recall (age :-) )

 

On mine the rear one is the speaker, the front is the passive.

They are held in (besides the screws) by a thin tape, easy enough to work free with a little bit of patience, prying etc.Same story for the control plate, remove the screws, and pry up gently.

 

 

 

 

Share this post


Link to post
Share on other sites
On 12/2/2016 at 7:11 PM, Amstaff said:

2 week update - 

 

I had forgotten how awesome this thing is - wife is playing some Rammstein as I type.

 

It is probably me - but it seems better than it ever was.

 

One happy camper here.

 

NICE.... glad you got your sub back up and playing....

 

Rammstein:emotion-21::emotion-21:

 

MKP :-)

Share this post


Link to post
Share on other sites
On 10/15/2016 at 9:20 AM, Amstaff said:

I am bummed. My 12+ year old RSW 15 has died. If I leave it plugged in and switched off for a few minutes and then switch it on - I get a brief red light (less than a second) and then nothing. Sometimes if I leave it plugged in and switched on - the red light will come on and stay on after about 30 to 45 minutes. Will never go green - and, obviously, no sound. Any ideas? Worth fixing?

 

This beast has been the cornerstone of our HT setup since we bought it (along with RF7s, RC7 and RS7s). It has been driven by a Yamaha RX-Z1 and now a Denon 4311Ci (the Z1 kicks the Denon's behind btw).

 

Dilema: what to replace the RSW 15 with? Does not have to be Klipsch - do they even have a comparable or better model today? What other brands/models do y'all suggest?

95+% of our HT use is movies.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...